License Agreement

By downloading or using this Software, you agree to be bound by the following legal agreement between you and the Alfred-Wegener-Institute for Polar and Marine Research (AWI). If you do not agree to the terms of this Agreement, do not download or use the Software.

1. SCIENTIFIC USE AND TEACHING

Ocean Data View can be used free of charge for non-commercial, non-military research and teaching purposes. If you use the software for your scientific work, please cite Ocean Data View in your publications as follows: Schlitzer, R., Ocean Data View, http://odv.awi.de, 2012.

2. COMMERCIAL AND MILITARY USE

For the use of Ocean Data View or any of its components for commercial or military applications and products, a special, written software license is needed. Please contact the address below for further information.

3. REDISTRIBUTION

Redistribution of the Ocean Data View software on CD-ROM, DVD, or other electronic media or the Internet is not permitted without the prior written consent of the AWI. Please contact the address below for further information.

4. WARRANTY DISCLAIMER

THE ODV SOFTWARE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE SOFTWARE IS WITH YOU. SHOULD THE SOFTWARE PROVE DEFECTIVE, YOU ASSUME THE COST OF ALL NECESSARY SERVICING, REPAIR OR CORRECTION.

IN NO EVENT WILL AWI, ITS CONTRIBUTORS OR ANY ODV COPYRIGHT HOLDER BE LIABLE TO YOU FOR DAMAGES, INCLUDING ANY DIRECT, INDIRECT, GENERAL, SPECIAL, EXEMPLARY, INCIDENTAL OR CONSEQUENTIAL DAMAGES HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY ARISING OUT OF THE USE OR INABILITY TO USE THE SOFTWARE (INCLUDING BUT NOT LIMITED TO LOSS OF DATA OR DATA BEING RENDERED INACCURATE OR LOSSES SUSTAINED BY YOU OR THIRD PARTIES, A FAILURE OF THE SOFTWARE TO OPERATE WITH ANY OTHER SOFTWARE OR BUSINESS INTERRUPTION).

© 1990 -2012  Reiner Schlitzer, Alfred Wegener Institute, Columbusstrasse, 27568 Bremerhaven, Germany. E-mail: Reiner.Schlitzer@awi.de
# Contents

1. **INTRODUCTION** ................................................................. 1
2. **COLLECTIONS** ................................................................. 1
   2.1 **ADDING OR DELETING META- AND COLLECTION VARIABLES** ...................... 1
3. **STATION MAPS** ................................................................. 1
   3.1 **MAKING CRUISE MAPS** ...................................................... 1
   3.2 **CUSTOM COASTLINES AND BATHYMETRY** .................................................. 2
   3.3 **CUSTOM GRIDDED BATHYMETRY FILES** ..................................................... 5
   3.4 **CUSTOM SECTION BATHYMETRY** ......................................................... 7
4. **DATA WINDOWS** ............................................................... 8
   4.1 **CUSTOM AXIS LABELING** ....................................................... 8
   4.2 **ADDING STATION LABELS TO SECTION WINDOWS** .................................. 8
   4.3 **VISUALIZING GRIDDING MISFITS** .................................................... 9
5. **OVERLAY WINDOWS** ......................................................... 11
   5.1 **CONTOUR LINES ON TOP OF A SHAPED FIELD** ........................................ 11
   5.2 **ARROWS ON TOP OF A SHAPED FIELD** ................................................. 12
6. **DATA QUALITY CONTROL** ................................................ 14
7. **IMPORTING XYZ DATA** ..................................................... 15
8. **PRE-COMPUTING NEUTRAL DENSITY** ................................. 16
9. **USING ODV GRAPHICS** ..................................................... 17
1 Introduction

This document contains in-depth descriptions on how to perform frequently occurring tasks with ODV.

2 Collections

2.1 Adding or Deleting Meta- and Collection Variables

The sets of meta- and collection variables in a given ODV data collection are defined when the collection is created. ODV allows modifying these variable sets at any time and lets you add new variables, delete existing ones or change the properties of existing variables using the Collection>Properties>Meta Variables or Collection>Properties>Collection Variables options.

You add a new variable by pressing the New button and specifying label, units, the number of significant digits (numeric variables only), the quality flag schema to be used for this variable, and the data type and byte length (TEXT variables only). Click OK to add the new variable to the end of the variable list and repeat this procedure for all new variables to be added.

You change the position of a given variable in the list by selecting that variable and clicking on the Top, Up, Down, Bottom buttons. You change the properties of an existing variable by selecting the variable and clicking on the Edit button. You delete an existing variable by selecting the variable and clicking on the Delete button. Note that mandatory meta-variables cannot be deleted.

After making the changes ODV will re-write the entire collection accommodating the new or modified variables in the new version. Please note that the new variables will not contain any data initially. You may selectively add data for the new variables and keep the data of other variables unchanged using the Merge Data (selected variables) import mode (see chapter 4.8 in the ODV User’s Guide).

3 Station Maps

3.1 Making Cruise Maps

You can create full-page, high quality stations maps showing the currently selected stations of the open data collection using View>Window Layout>Layout Templates>Full Screen Map. Station maps may also be produced if you only have access to the station metadata (e.g., station positions, dates, etc.), but the actual station data are inaccessible. Here is how to proceed:
• In an empty directory on your disk create an ASCII file that contains the longitude, latitude coordinates of the stations or way-points of your track. This file should have a descriptive name (e.g., CruiseTrack_xxx.txt, where xxx represents the name of your cruise) and it should comply with the generic ODV spreadsheet format specifications.

As first line of the file use the following header line (note that columns are TAB separated):

<table>
<thead>
<tr>
<th>Cruise</th>
<th>Station</th>
<th>Type</th>
<th>yyyy-mm-ddTh:mm</th>
<th>Longitude [degrees_east]</th>
<th>Latitude [degrees_north]</th>
<th>Bot. Depth [m]</th>
<th>Dummy1</th>
<th>Dummy2</th>
</tr>
</thead>
</table>

Immediately following the header line, add one data line for each station or cruise track node and provide the following information for the respective station or node:

| Cruise | The name of the cruise | Station | Station label or number | Type | “B” | yyyy-mm-ddTh:mm | Station date and time | Longitude [degrees_east] | Decimal longitude of station | Latitude [degrees_north] | Decimal latitude of station | Bot. Depth [m] | Bottom depth at station location or “0” | Dummy1 | “0” | Dummy2 | “0” |

• On Windows systems drag-and-drop the prepared cruise track file on the ODV desktop icon. On all other platforms start ODV and open the cruise track file via File>Open and choosing file type Data Files (*.txt *.csv *.o4x).

• Add new stations to the end of the cruise track file, if necessary, and drag-and-drop the updated file on the ODV desktop icon (Windows) or invoke ODV using the cruise track file name as a command line argument (all other platforms).

### 3.2 Custom Coastlines and Bathymetry

ODV comes with a medium resolution global set of coastline and bathymetry files (GlobHR). Higher resolution versions of coast/bathymetry data are available as optional packages for selected regions, such as the Arctic, Baltic, NorthSea, MeditHR and many others. If you need high-resolution coastline and bathymetry files for a region not included in the ODV distribution and if you have such high-resolution data available, here is how to produce ODV usable files.

**Preparing New Files**

The data for the coastline and bathymetry contours must be in separate files. Use World.coa as name for the coastline file. The names of the bathymetry files must follow the xxxm.coa scheme, where xxx represents the depth value of the respective contour (no white space between the depth value and the m; example: 1000m.coa). For a sample .coa file see the samples directory of your ODV installation.
The latitude/longitude coordinates of the coastline or depth contour are stored in individual polygon segments (see Figure below). The first \( n_S \) nodes of a segment represent a part of the actual coastline or bathymetry contour. This part of the segment is stroked when the outline of the contour is requested. In addition, each segment can have an optional, second part which will not be stroked but is only used to properly close the segment. Segments that also contain this second part can be filled and/or stroked. The total number \( n_T \) of nodes in any segment must not exceed 1500. If a segment has no second part, the number of stroke points \( n_S \) must be equal to \( n_T \).

![Figure 3-1: Schematic diagram of an ODV coastline/bathymetry segment.](image)

Latitude/longitude coordinates are decimal values: longitude is in degrees East (0 – 360) and latitude is in degrees North (-90 – 90). A polygon segment in a .coa file is specified as follows:

\[
\begin{align*}
\text{n}_T & \quad \text{n}_S \\
\text{lat}_1 & \quad \text{lon}_1 \\
& \quad \vdots \\
\text{lat}_{n_T} & \quad \text{lon}_{n_T}
\end{align*}
\]

where \( n_T \) is the total number of vertices for this segment and \( n_S \) is the number of "true" coast/bathymetry vertices. \( n_T \) may be larger than \( n_S \) in which case vertices \( n_S + 1 \ldots n_T \) are used to close the segment (land-side closure). These extra vertices are not shown when the segment is stroked. Note that both, \( n_T \) and \( n_S \), must be smaller than 1500. On the line following the last vertex of a segment, the next segment is started by specifying its \( n_T \) and \( n_S \) values. There is no blank line between segments. To indicate the end of the file put "0 0" in the last line of the file. .coa files have to be converted to binary format (.cdt files) before they can be used by ODV. A .coa to .cdt converter (coa2cdt.exe) is included in the ODV distribution package for Windows. To use the coa2cdt converter do the following:
1. In the directory containing the .coa files create a file coa2cdt.inp and enter the names of the .coa files to be processed. Put one file name per line and omit the .coa extension.

2. In a DOS box change to the respective directory and execute coa2cdt.exe. Make sure the coa2cdt.exe executable is in your path or in the .coa directory. Also make sure that the .coa files satisfy the .coa format, as described above.

The .cdt files created by coa2cdt.exe are platform-independent and can be used on all supported platforms.

Please note that if you want to fill the bathymetry and coastlines, you have to close all polygons in the .coa files, and the interior of the polygons must represent the areas that are shallower than the respective depth contour or coastline. If your depth contours or the coastline does not consist of closed polygons, you can still use them with ODV, however, you should select a line drawing mode and avoid filling in those cases. Use the Display Options menu of the map to change display settings accordingly (see Using New Files below).

Installing New Files
When installing the binary version of coastline-, bathymetry-, topography and overlay files follow these instructions:

- Create a new subdirectory of the ODV coast directory (normally: c:\Program Files\Ocean Data View (mp)\coast) and choose a descriptive name for it (e.g., GulfOfMaine). This directory is the base directory of the new file series. In the new directory create subdirectories bathymetry, topography, and overlays.

- Copy the coastline file (normally called World.cdt) into the series base directory (e.g., c:\Program Files\Ocean Data View (mp)\coast\GulfOfMaine).

- Copy all bathymetry files (e.g., 100m.cdt, 500m.cdt, etc.) into the bathymetry subdirectory, all topography files into the topography directory and all general purpose overlay files (rivers, lakes, borders, etc.) into the overlays directory. If no topography and/or overlay files are available the respective directories remain empty.

- If you want the new custom series to be used by ODV in automatic series selection, you must create a text file containing information on the domain and resolution of your series. The file name must be the same as your series name, and the extension must be .settings. In the example above, the file name would be GulfOfMaine.settings. The file must be located in the series’ base directory, e.g., in c:\Program Files\Ocean Data View (mp)\coast\GulfOfMaine. The format and contents is described below.

### Example .settings file:

```
[Domain]
EastLongitude = 12.
NorthLatitude = 63.0
```

### Contents:

Domain longitudes are decimal degrees east (negative for deg W), latitudes are decimal degrees north (negative for deg S). Domains extending across the Greenwich me-
Using New Files

To use the newly installed files in ODV maps do the following:

- Invoke the map Display Options dialog box (e.g., right-click the mouse while over the map and choose Display Options) and select the Layers tab.
- Choose the newly installed series name (e.g., GulfOfMaine) in the Series combo-box.
- Compose the layer-set(s) of interest by selecting a layer-set (e.g., Ocean Bathymetry) and then pressing Compose. Select the contour files that you want to use in the Available list, set the desired stroke and fill properties and finally press << to add the files to the Selected list (note: if you forget to press << no file is added). To remove files from the Selected list select them and press >>.

When specifying drawing characteristics follow these rules:

(a) If the features should be outlined by lines (stroked), choose the appropriate line-width, -type and -color or choose none as color, if you don’t want outlines. Note that due to limitations of the operating system, on some Windows versions thick lines will always be drawn as solid lines on the screen and in GIF, PNG and JPG output files. ODV PostScript files, however, honor your selection for any line-width.

(b) If the features should be filled choose the appropriate Fill color or none, if you don’t want filling.

If you choose automatic for line and fill colors, ODV will use default colors. Note that for some layer sets the automatic setting defaults to none. Also note that some feature files like rivers or borders should not be filled and you should explicitly set the fill color to none.

ODV processes the layer sets in the order as listed in the Display Options dialog box. For a given layer set it draws the individual layers in the order in which they appear in the Selected list (note that ocean bathymetry and land topography layers are sorted automatically when they are added). You should define sea-ice distributions in the pre-Coastlines set and lakes, rivers and borders in the post-Topography category.

3.3 Custom Gridded Bathymetry Files

Included in the ODV software distribution you find the gridded global bathymetric data of GEBCO 2003 subsampled to 6’x6’ resolution (file GEBCO1.nc in directory <install>/include). These data are used by ODV for two purposes: (1) the section bathymetry polygon when using sections and choosing GEBCO1.nc for section bathymetry, and

<table>
<thead>
<tr>
<th>SouthLatitude = 47.5</th>
<th>WestLongitude = -5.</th>
</tr>
</thead>
<tbody>
<tr>
<td>[Resolution]</td>
<td></td>
</tr>
<tr>
<td>LatitudeRes = 0.015</td>
<td>LongitudeRes = 0.015</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Elemen have negative westLongitude but positive EastLongitude. Resolution is given as decimal degrees.</td>
</tr>
</tbody>
</table>
(2) for construction of the gridding domains and sub-domains when using DIVA gridding in maps.

While the resolution of the bathymetric data in GEBCO1.nc is sufficient for long sections and for basin-wide gridding domains, this is no longer the case when dealing with short sections or small gridding domains. If you have high-resolution gridded bathymetric data available for your area of interest you may create your own high-resolution bathymetry file and use this resource for section bathymetry or DIVA domain selection.

Your custom bathymetry file must be in netCDF format, have the .nc extension and contain elevation data on a regular longitude by latitude grid. Elevation values must be positive on land and negative in the ocean. The netcdf file must have the following structure:

```
netcdf XXXXX {
    dimensions:
        lon = 3601 ;
        lat = 1801 ;
    variables:
        float lon(lon) ;
            lon:long_name = "Longitude" ;
            lon:units = "degrees_east" ;
            lon:range = "-180 - 180" ;
        float lat(lat) ;
            lat:long_name = "Latitude" ;
            lat:units = "degrees_north" ;
            lat:range = "90 - -90" ;
        short Height(lat, lon) ;
            Height:long_name = "Elevation" ;
            Height:units = "m" ;
}
```

The names of dimensions and variables as well as the data types and the order of dimensions in the Height variable have to be exactly as given. Obviously the lengths of the lon and lat dimensions depend on the size of your grid, and the name of the file XXXXX is arbitrary. Note that the Height variable only stores the integer part of the elevation data. This limits the depth resolution in the file to ±1 m.

Once created move the custom bathymetry file to the <install>/include directory. You use the custom bathymetry data for the section bathymetry polygon by choosing the newly created file under Bathymetry>File on the Section Properties dialog. To use the new bathymetry file for DIVA domain selection choose the file under DIVA Settings>Map>File on the window’s Properties dialog.

3.4 Custom Section Bathymetry

By default the bathymetry polygon of sections is constructed using the Bot. Depth metadata of the stations. Alternatively, you can also use gridded bathymetric data from the `<install>/include/GEBCO1.nc` file or your own custom bathymetry (see previous section). As a third (and preferred) option you can construct the bathymetry polygon using along-track shipboard bathymetric data and provide the bathymetry polygon as .gob ODV graphics object file. This method will usually result in the most detailed and accurate representation of the section bottom bathymetry and is recommended whenever shipboard bathymetric data are available.

The section bathymetry .gob file must have the following structure (see also `A7_bathymetry.gob` example file in `<install>/samples/SampleFiles.zip`):

```
%GOB1.03 graphics objects

:POLYGON
coordinates=1
clip=1
iOrder=1
isFixed=1
doSmooth=0
LineColor=16
LineType=0
LineWidth=3
FillColor=16
nPts=1187
nStrokePts=1184

12.6183 60.8
11.6183 60.8
11.5791 68.7
11.5747 69.4
11.5347 89.6
...
-36.9634 232.9
-36.9634 9500.
12.6183 9500.
12.6183 60.8
```

The first 14 lines of the file describe the graphical appearance of the polygon and its length. Then follow the X and Y coordinates of the polygon nodes, one node per line. The X values represent Section Coordinate values (Section Distance [km] or Longitude or Latitude as chosen for the section), while Y is ocean depth in meters (positive downward). [For your information, the example above uses latitudes for X.] The first nStrokePts nodes of the section polygon describe the bathymetry along the section; the last three nodes are needed to close the polygon.

The format of the final 3 nodes is as follows:

- Last X Huge Y
- First X Same huge Y
The *Huge Y* of the closure points (9500 m in the example above) should exceed the maximum depth in the section plots. The maximum number of nodes $nPts$ of the polygon is 1500. You may have to subsample the shipboard bathymetry data to stay within this limit.

Once created you use the *.gob* bathymetry file for the section bathymetry polygon by choosing the file under Bathymetry>File on the Section Properties dialog.

## 4 Data Windows

### 4.1 Custom Axis Labeling

The labeling of X- and Y-axis of data windows is performed automatically by default. This includes automatic determination of labeled and unlabeled tic mark positions and the use of the variable’s label as axis title.

You may customize the frequency of labeled and unlabeled tic marks by clicking on X-Axis Settings or Y-Axis Settings buttons on the Properties>Data page of the window’s Properties dialog and specifying values for Tic mark interval and Label Interval.

You may switch off the automatic use of the variable’s label as axis title and use of a custom axis title in the following way:

1. Right-click the mouse while being over the existing X-axis title and choose option Copy Object. Do the same for the Y-axis. This will create editable and moveable copies of the existing annotations.
2. Uncheck the Automatic axis titles box on the Properties>General page of the window’s Properties dialog.
3. Drag the annotations created during (1) to their desired positions and change the text by right-clicking on the annotation and choosing Properties.

### 4.2 Adding Station Labels to Section Windows

Station labels can be added along the top margin of section plots (see Figure below) in the following way. First export the station labels as ODV annotation objects to a *.gob* file using option Extras > Export as Graphics Object > Section Station Labels. If necessary then edit the *.gob* file to delete some entries in areas of dense station spacing or change the color or font size of specific entries. Finally add the labels to the section window via option Extras>Import Graphics Object from File>GOB File.

If the station labels overlap with the Z-variable label (*Oxygen* in the example figure below) move this label upward. Note that if the Automatic axis titles option on the Proper-
ties > General page is checked this procedure has to be repeated after every redraw of the data window. You can avoid this by creating copies of the axis labels (Ctrl-C with the mouse over the respective label), unchecking the Automatic axis titles option and properly placing the axis labels ones and for all.

Note that the station labels along the top margin are implemented as ODV graphics objects. You can manually change the properties of a given object by moving the mouse over it, right-clicking the mouse and choosing the Properties option, or simply by pressing Alt-P while the mouse is over the label. The easiest way to delete individual labels is to put the mouse over it and pressing the Del button.

![Figure 4-1: Section plot with selected station labels along the top margin.](image)

### 4.3 Visualizing Gridding Misfits

Gridding algorithms allow the estimation of tracer values at arbitrary \((x, y)\) points based on data values at sampling locations \((x_i, y_i), i=1...n\). The objective is to reproduce the features in the data as realistically as possibly. However, because of errors in the data it is generally not desirable to achieve a perfect match with the data at the sampling locations, but to allow some misfits. Ideally, these misfits should show no systematic spatial patterns, the mean of the misfits should be close to zero, and the standard deviation of the misfits should be close to the error in the data. However, gridding algorithms often have problems to correctly reproduce sharp gradients or property extremes, and, in order to assess the quality of a given gridded field, it becomes necessary to view and analyze the distribution of the gridding misfits.

The easiest way to produce a plot of estimate-data misfits at the data locations is via the data window’s statistics dialog (Extras>Statistics option or press F4 while mouse is over...
the data window). Pressing the Gridding Misfits button will create a misfit plot similar to the one shown in the lower part of Figure 3-2 below.

ODV also allows exporting the x, y, z data values as well as the gridding misfits at the data locations using the Extras > Clipboard Copy option of the respective window context menu (obtained by right-clicking on the window). You may also simply press Ctrl-C while the mouse is over the respective window. On the Copying to Clipboard dialog that appears make sure to select Export data values and gridding misfits at data positions and check the Export station metadata box. ODV will then export the results to the clipboard. Open a text editor or Excel and paste the clipboard contents into it; then save the contents to an ASCII file. Choose .txt as file extension.

Drop the newly created .txt file onto the ODV icon or open a new ODV instance and use File > Open to open the .txt file. Use option View > Layout Templates > 1 SCATTER Window to obtain a layout with a single SCATTER window and adjust the geometry of the window to match the geometry of the original window. Assign the X and Y variables of the original window as X and Y variables of the SCATTER window, and select the Estimated-Measured... variable for Z. You should obtain results as shown in Figure 5-1.

For the example shown in the Figure below the misfits are small and random in many parts of the deep ocean. Significant and systematic misfits are found in areas of sharp gradients and just south of the equator, where data from two different cruises overlap. You can obtain further statistical information via the Extras > Statistics option or by pressing F4 while the mouse is over the misfit window.
5 Overlay Windows

5.1 Contour Lines on top of a Shaded Field

It is often useful to create section or isosurface plots where the distribution of one property (color shaded and/or contoured) is overlaid with contour lines of another property. Useful applications, of this technique are, for instance, density contours on top of any property section or depth contours on isosurface or isopycnal distributions. Example images are shown in Figures 4-1 and 4-2 below.

To produce such plots, follow these steps:

- Switch to window layout mode via View>Window Layout.
- Setup the window for the underlying distribution (window a: define size and position; select a Z-variable for that window (property A) using the Properties option).
- Create an overlay window for window a by moving the mouse over window a, clicking the right mouse button and selecting Create Overlay Window. Now select the Z-variable for the overlay window b (property B). Leave Window Layout mode by choosing Accept from the Window Layout context menu.
- ODV will draw a default set of white contour lines for property B on top of the color distribution of property A. You may add or delete lines or modify properties of the contour lines of B by right-clicking on the overlay window by choosing Properties>Contours.
- If satisfied, save the view for later use (View>Save View As).

Note that the only way to access and modify the properties of a data window entirely overlain by another window (such as window a), is via the main menu View>Window Properties option.
5.2 Arrows on top of a Shaded Field

It is often useful to create maps where the distribution of one property (color shaded and/or contoured) is overlaid with arrows of another vector property, such as ocean
current velocities or atmospheric winds (see Figure 4-3 below).

Figure 5-3: Map showing wind arrows on top of color shaded distribution.

To produce such plots, follow these steps:

- Switch to window layout mode via View>Window Layout.
- Setup the window for the underlying distribution (window a: define size and position; select a Z-variable for that window (property A), specify the display style, and possibly create some contour lines using the Properties option).
- Create an overlay window for window a by moving the mouse over window a, clicking the right mouse button and selecting Create Overlay Window. Now select a Z-variable for the overlay window b (property B) that could be used for automatically coloring the arrows.
- Edit the properties of the newly created overlay window by right-clicking on the window and choosing the Properties option (shortcut: Alt-P with the mouse over the window). On the Display Style page click on Original data, then on the combo box just below, and choose Arrows. Under X/Y Components choose the variables for the X and Y arrow components, and then specify a scale, line width and color. Choosing (automatic) will automatically set the arrow colors on the basis of the Z variable of the overlay window (property B). If you want all arrows having the same color, choose this color from the Color combo box.
- Leave Window Layout mode by choosing Accept from the Window Layout context menu.
• ODV will draw the arrows of the overlay window on top of the color distribution of property A.

• If satisfied, save the view for later use (View>Save View As).

Note that the only way to access and modify the properties of a data window entirely overlain by another window (such as window a), is via the main menu View>Window Properties option.

## 6 Data Quality Control

ODV facilitates quality control of multi-parameter datasets by providing a range of automatic and visual checks for easy identification and flagging of outliers and suspicious data. There is support for automated range checks of any basic variable (use option Tools>Find Outliers (Range Check)) as well as automatic statistical outlier checks for any data window currently applying the VG gridding method (use option Extras>Find Outliers (Field Check) of the data window’s popup menu). In both cases, ODV generates lists of suspicious data points and allows user controlled (point by point) or automatic flagging of the identified data.

In addition to automatic quality control procedures, ODV also provides a wide range of easy-to-use visual and interactive methods for the identification and editing of outliers. For instance, you can plot all data from a given region or along a given section using data windows of SCATTER or SECTION scope, easily revealing outliers and questionable data in the entire dataset. Flagging or editing the numerical values of the spurious data is as easy as clicking on such a data point in one of the data windows and invoking the Edit Data option of the variable that you want to modify. Note that all changes made to a data collection are logged in the collection logfile. The log record includes information about the sample that was changed, the date and time of the modification, the user who made the change and the computer on which the operation was performed. You can browse the collection logfile at any time using option Collection>Browse Log File.

In the example below, outliers for salinity and oxygen can easily be spotted in the plots showing the data of an entire cruise. Clicking on such an outlier point selects it as current sample, which can then be edited and/or flagged. You can hide and exclude bad or questionable data from the analysis by establishing data quality sample filters.
7 Importing XYZ Data

Irregularly spaced or gridded data for some quantity \( Z \) at given \( X \) and \( Y \) coordinates are commonly provided in files using three-columns for the \( X \), \( Y \) and \( Z \) values, respectively. Examples of such XYZ datasets are (1) maps of a given \( Z \) variable (\( X \) represents longitude, \( Y \) represents latitude), (2) vertical sections (\( X \)=along section coordinate, \( Y \)=depth) or (3) time-evolution plots (\( X \)=some geographical coordinate, \( Y \)=time or vice versa).

You can load all these XYZ files into ODV and you can analyze and display the \( Z \) data using the full suite of ODV functions. Note that the procedures described below can also be applied to data files with multiple \( Z \) variables, e.g., files with more than three columns.

Here is how to proceed if the XYZ file represents a map:

1. Create a new collection (choose a destination directory and collection name) with just two variables Depth [m] and \( Z \)-variable (use a descriptive label and appropriate units for the \( Z \)-variable),

2. Import the XYZ file by choosing Import>ODV Spreadsheet and selecting the XYZ file (note that you have to choose file-type All Files, if the extension of the XYZ file is not .txt).

3. On the Spreadsheet File Properties dialog specify (1) the column separation character (the items from the header line should appear on separate lines in the Column Labels list), (2) the line number containing XYZ labels (keep 1, if no labels are provided), and (3) the line number of the first data line,

4. On the Metadata Variable Association dialog associate the \( X \)-variable with Longitude [degrees_east] and the \( Y \)-variable with Latitude [degrees_north],

5. On the Import Options dialog associate the \( Z \)-variable (source) with the second collection variable (target). Then click on the first collection variable (target),
click on Use Default and specify the default depth value (use 0, if in doubt).

ODV will import the data from the XYZ file, and lets you operate on the data in the usual way. To create a page with a map of the Z-variable create a data window with SURFACE scope. Modify the data window’s properties as usual, if this is necessary.

8 Pre-computing Neutral Density

Compared to most other derived variables, such as potential temperature, potential density, or Brunt-Väisälä Frequency, that can be calculated easily and quickly on-the-fly, the calculation of neutral density is computationally expensive. While this is not a problem for small data collections or when plotting only a small number of stations, using on-the-fly neutral density calculations with large collections and on long sections can be slow and inefficient. If you are working with large datasets and need neutral density regularly, you should consider to pre-compute neutral density and store the results in collection files on disk. You can then use the pre-computed values from the disk files. The disadvantage of pre-computing and storing these values is that they become out-of-date if any of the input data pressure (or depth), temperature and salinity changes (e.g., after data edits or calibration changes). It is the user’s responsibility to re-compute the neutral density values whenever pressure (or depth), temperature or salinity data have changed or have been added.

To create a new collection with pre-computed neutral density values for all stations or a station subset of an existing data collection follow these steps:

1. Open the existing collection and select the stations to be included in the new collection with pre-computed neutral density. If you want to process the entire collection, make sure you have a global map and the number of selected stations is identical to the number of stations in the collection (e.g., two numbers at the end of the status bar should agree).

2. Define Neutral Density as a derived quantity using option View>Derived Variables.

3. Export the station data including neutral density to a spreadsheet file, by choosing Export>ODV Spreadsheet. Specify a name for the new dataset (denoted as xxx.txt in the following) and make sure that Neutral Density is selected for output in the Select Variables for Export list.

4. Use xxx.txt to create a new collection by simply dragging and dropping this file on the ODV desktop icon (Windows and some other platforms) or by starting ODV from a terminal window with “odvmp xxx.txt” (UNIX, Linux, Mac OS X). The newly created collection xxx will have Neutral Density as one of its basic variables stored in the disk files.
9 Using ODV Graphics

ODV graphics files of the entire canvas or individual data windows can easily be included in print documents, posters or on Web pages.

To create GIF, PNG, JPG or TIFF files of the entire canvas or of individual plots press Ctrl-S while the mouse is over the canvas or the respective plot window and choose GIF, PNG, JPG or TIFF as output type. Then specify the desired resolution of the saved image and use the GIF, PNG, JPG or TIFF graphics files in your web pages or in text documents. For print documents you can either produce raster image files with high resolution, or you can use ODV PostScript (.eps) output instead.

A number of typesetting and page design software applications support the import of Encapsulated PostScript files (.eps) in mixed text/graphics pages (e.g., MS Word or compatibles, LaTeX, Adobe PageMaker, etc.). If you use the LaTeX typesetting system, see the file Pssample.tex (usually in directory c:\Program Files\Ocean Data View (mp)\Samples) for an example on how to include PostScript graphics in TeX documents. Note that the required epsf and epsfig style files are also included in the samples directory.

If you use Word or PageMaker or other publishing software follow these guidelines: Compose your page as usual and insert the respective ODV PostScript file at the right position. Adjust the size of the figure appropriately. When you are done composing the page you can directly print the document on a PostScript printer. If no PostScript printer is available you need to have a PostScript printer-driver and the GhostScript/GhostView package (http://www.cs.wisc.edu/~ghost/aladdin/index.html) installed on your machine. In that case select the PostScript printer-driver as printer and redirect the output into a file. Open this file with GhostView and print to any printer connected to your system.